All of the above are required